Immanuel Website Help Page

We want to thank you for visiting our website. Every effort has been made to make this website easy to access, easy to use, and easy to understand. Because the most popular Internet browsers are Internet Explorer (from Microsoft) and Firefox (from Mozilla), these are the ones for which the programming has been optimized. Other browsers should work for most pages, but may not work for every page.

Having said that, we realize that as hard as we may try, you may still experience difficulty in using and/or access our web pages (even if you are using Internet Explorer or Firefox). If you should encounter any trouble, either with a particular page or with the website in general, please feel free to let us know. You can do so by either sending us an email using our online Email Form or sending an email directly to our webmaster at ilcsteger.webmaster@gmail.com.

Thank You!

 

Additional Notes:
This website uses javascript for many functions including the main menu. If you do not have javascript enabled, these functions will not work and you will not be able to easily maneuver about the website. The email form also uses javascript for field content checking as well as server-side scripting to execute the sending of your email. If you do not have it enabled, you should still be able to go to our Site Map and access other pages on our website. If you do not have javascript enabled, please consider doing so since many websites depend on it for providing a user-freindly experience (including ours).

Some content such as the Twin Spires and the Weekly Bulletin is presented in PDF formatted files. The main reason for that is because it is easiest to convert from their original format into a PDF file (as opposed to a web page) and still maintain most of the same formatting and readability. If you do not have Adobe Acrobat Reader (or comparable program) installed, you can download and/or install it from http://get.adobe.com/reader/.

We also now present audio versions or our Sunday sermons. To listen to them online, you will need to have Adobe Flash Player Installed. While older versions 8 and 9 will work, it would be best to have version 10 or later installed. You can get that at Adobe's website at http://www.adobe.com/products/flashplayer/.